Olympus OM-4Ti with Olympus G.Zuiko Auto‑W 2.8/35mm

Well, this time I planned tak­ing the Olym­pus OM-4Ti with me in on a hik­ing trip to South-Tir­ol — besides my work­horse, the Olym­pus OM‑D E‑M1. Planned it and pre­pared it and … while test­ing if finally everything works fine … the OM-4Ti refused to fire.

 

Olym­pus OM-4Ti with G.Zuiko Auto‑S 1.4/50mm (yep, not the cor­rect lens)

Olym­pus G.Zuiko Auto‑W 2.8/35mm

Bat­ter­ies changed, read­ing the manu­al, search­ing the web … noth­ing worked and I finally had to accept that this beau­ti­ful wun­der­werk will not go with me.

So here I can close this short post, as this combo will not be in the focus this time. I searched on the web for a repair shop in Ger­many and found the legendary OM-Dok­t­or in Ham­burg. Long story short … par­cel is on it’s way to repair this cam­era.

What to do now?
Grabbing anoth­er OM out of the cam­era case — this time an OM‑2 spot/program. But this is anoth­er story.

In case you’d like to com­ment, it’s appre­ci­ated … and maybe, you want to check out my web­site too!

Enjoy

P.S. … and don’t for­get my Flickr page.

Tags: , , , , , , , , ,

3 Responses to “Olympus OM-4Ti with Olympus G.Zuiko Auto‑W 2.8/35mm”

  1. walker says:

    hik­ing w/ an OM-xx, whatever xx may be, is simple great ;)

    • admin says:

      Hi Walk­er, I hope so, even if it’s now a OM-2sp ;)
      The OM 4Ti is already on its way back from the repair shop.

  2. walker says:

    I mean “simply” sorry

Leave a Reply